Centre d'assistance

Filtrer des rapports d’enquête

Pas de commentaire

Le filtrage est un excellent moyen d’affiner les résultats affichés dans votre rapport, d’acquérir de nouvelles connaissances sur la façon dont différents groupes démographiques ont répondu à votre enquête et de voir comment des variables différentes sont liées. Parfois les filtres que nous créons sont assez compliqués par nécessité, et nous voudrons les réutiliser plus tard. Vous pouvez enregistrer les filtres dans votre rapport afin de ne pas devoir les reconstruire à partir de zéro à chaque fois.

Vous pouvez filtrer sur des questions et des métadonnées que vous avez transmises à l’enquête ou sur des métadonnées des répondants que le système capture automatiquement, ou sur toute combinaison de ces options.

Hiérarchie

Comprendre la hiérarchie de l’application des filtres est la clé pour tirer le meilleur parti du ReportBuilder.

Vous pouvez ajouter des filtres sur quatre niveaux :

  • Rapport : c’est le filtre global de niveau supérieur. Ajouter un filtre sur ce niveau, affecte tous les éléments de votre rapport. Vous pouvez outrepasser ce filtre pour une source de données spécifique dans un élément, comme un benchmark.
  • Source de données : chaque élément de votre rapport a au moins une source de données. Vous pouvez définir un filtre pour chaque source de données indépendamment. Si vous définissez un filtre au niveau de l’élément et il y a déjà un filtre au niveau du rapport, la source de données respectera à la fois le filtre du rapport et son propre filtre, à moins que vous ne le définissiez pour ignorer les autres filtres (benchmark).
  • Partage : un rapport peut avoir plusieurs partages et chaque partage peut avoir son propre filtre. Un filtre de partage affecte le rapport entier quand il est consulté via le lien de partage. S’il y a des filtres actifs au niveau du rapport et / ou de la source de données, le filtre de partage respectera également ces filtres, à moins que vous ne définissiez une source de données pour ignorer des autres filtres (benchmark).
  • Visionneuse : vous pouvez également donner à un visiteur d’un rapport l’option de filtrer plus en profondeur les données. Ils ne peuvent ni supprimer ni outrepasser aucun autre filtre (rapport, source de données, partage), mais uniquement filtrer plus profondément jusqu’à ce qu’ils atteignent la limite minimale des répondants (le cas échéant).

Gérer les filtres

Étant donné que les filtres peuvent être réutilisés à différents endroits, il est important de leur donner un nom clair expliquant l’activité du filtre. Utiliser de bons noms, facilite énormément la gestion et la réutilisation. Veillez également à mettre à jour le nom du filtre si vous modifiez un filtre. Sinon, vous pourriez avoir une déconnexion. Par exemple, vous avez un filtre appelé “Le mois dernier” qui filtre en réalité l’année dernière.

Les filtres peuvent être créés et appliqués à plusieurs endroits dans le ReportBuilder. Peu importe où le filtre est créé, vous pouvez les gérer depuis un seul endroit.

  1. Allez vers le ReportBuilder et modifiez votre rapport.
  2. Cliquez sur la roue dentée Survey report cogwheel en haut à droite et sélectionnez Options.
  3. Cliquez sur l’onglet Filtres.

Maintenant vous voyez tous les filtres du rapport et si un filtre global a été activé. Vous pouvez voir où chaque filtre est utilisé en survolant le badge En usage. Ici, vous pouvez également ajouter, modifier et supprimer des filtres.

Dans l’éditeur du rapport, les filtres ne sont pas exclusifs à un utilisateur donné. Si l’utilisateur A crée un filtre dans un rapport, alors l’utilisateur B le verra également et pourra l’utiliser.

Modifier un filtre

Les filtres peuvent être créés dans des différents endroits dans le ReportBuilder. Une fois créé, le filtre peut également être appliqué à des différents endroits. Vous trouverez l’option pour ajouter un filtre partout où vous pouvez appliquer des filtres, généralement comme dernière option dans la liste des filtres. Vous pouvez également ajouter un filtre dans le menu où les filtres sont gérés. Lorsque vous cliquez sur le bouton “Ajouter un filtre”, un tiroir glissera vers le haut. Jetons un coup d’œil à la disposition de ce tiroir :

Survey report filters drawer
  1. Nom du filtre : donnez chaque filtre un nom court et descriptif qui clarifie ce que le filtre fait. Veillez à maintenir synchronisé le nom, si vous modifiez les conditions du filtre. Par exemple, un filtre portant le nom “mois dernier” et dont la condition change vers l’année dernière.
  2. Afficher dans Visionneuse : certains filtres peuvent être intéressants pour ceux qui consultent le rapport. En sélectionnant cette option, ce filtre sera disponible pour les visiteurs de la Visionneuse en tant que filtre prédéfini qu’ils puissent appliquer. Vous pouvez trouver plus de détails ci-dessous.
  3. Conditions : c’est ici que vous définissez les critères auxquels les répondants doivent correspondre pour passer à travers le filtre et pour être inclus.
  4. Enregistrer ou Annuler : une fois prêt, vous pouvez enregistrer le filtre ou annuler vos changements.

Les conditions d’un filtre

Pour bien maîtriser les conditions, il faut mettre votre casquette informatique et penser comme un ordinateur (c’est une pensée purement logique).

Survey report filter conditions
  1. Correspondance : pensez-y comme “et” & “ou”.
    • Toutes : seulement les répondants qui correspondent à toutes les conditions seront inclus.
    • Au moins une de : si une ou plusieurs conditions seront vraies pour un répondant, il sera inclus.
  2. Source de données : sur quoi souhaitez-vous filtrer ? Cela peut être une question, ou des métadonnées collectionnées par le système.
  3. Opérateur : comment souhaitez-vous tester les données ?
  4. Valeur : la valeur à comparer à la source de données.
  5. Poubelle : supprimez cette condition de ce filtre.
  6. Ajouter une condition : ajoutez une condition supplémentaire à ce filtre.

Filtrer au niveau du rapport

Le filtre que vous définissez au niveau du rapport est le filtre global. Il sera appliqué à tous les éléments d’un rapport, sauf aux sources de données qui ignorent des autres filtres (le benchmark).

  1. Allez vers le ReportBuilder et modifiez votre rapport.
  2. Cliquez sur la roue dentée Survey report cogwheel en haut à droite et sélectionnez Options.
  3. Allez vers l’onglet Filtres.
  4. Cliquez sur Ajouter un filtre.
  5. Modifiez le filtre comme décrit dessus et cliquez sur Enregistrer.
  6. Sélectionnez le filtre que vous venez de créer dans le menu déroulant Filtre global pour l’appliquer à tous les éléments de ce rapport.

Filtrer au niveau de l’élément

En plus du – ou outre le – filtre global, vous pouvez également définir des filtres uniquement pour certains éléments. Cela signifie que seulement l’élément sélectionné sera filtré en fonction des conditions définies.

Ainsi, vous pouvez, par exemple, créer le même graphique plusieurs fois, chacun avec un filtre différent. Un cas d’utilisation très courant est d’afficher les moyennes des scores de satisfaction des employés pour de différents départements. Modifiez les titres des éléments (via l’onglet Texte) ou ajoutez des éléments Texte et média pour clarifier la différence entre les éléments filtrés.

  1. Allez vers le ReportBuilder et modifiez votre rapport.
  2. Cliquez sur l’élément que vous souhaitez filtrer.
  3. Allez vers l’onglet Données.
  4. Dans le menu déroulant Filtre cliquez sur Ajouter un filtre.
  5. Donnez un nom au filtre.
  6. Décidez si vous souhaitez afficher le filtre dans la Visionneuse oui ou non. Si vous l’affichez dans la Visionneuse, chacun qui a accès à un partage du rapport pourra sélectionner ce filtre.
  7. Ajoutez une ou plusieurs conditions. Vous pouvez filtrer sur les métadonnées des répondants, les métadonnées des contacts, une question de l’enquête, ou une combinaison de celles-ci.
  8. Sélectionnez si les résultats doivent correspondre à au moins une de ces conditions ou à toutes ces conditions.
  9. Cliquez sur Enregistrer.

Le filtre sera appliqué à cet élément immédiatement.

Et quand vous sélectionnez d’autres éléments, vous verrez que ce même filtre sera aussi disponible dans le menu déroulant Filtre. Ainsi vous pouvez appliquer le même filtre aux plusieurs éléments de manière facile et rapide.

Conseil ! Si vous souhaitez appliquer un filtre à tous les éléments, définissez-le comme Filtre global dans les paramètres du filtre de rapport.

Filtrer au niveau du partage

Lorsque vous partagez des résultats avec différentes parties prenantes et vous souhaitez vous-même conserver un aperçu global, vous pouvez appliquer des filtres uniquement au niveau du partage.

  1. Allez vers le ReportBuilder et modifiez votre rapport.
  2. Cliquez sur la roue dentée Survey report cogwheel dans le coin en haut à droite et cliquez sur Partager.
  3. Cliquez sur Ajoutez un partage.
  4. Dans le menu déroulant Filtre supplémentaire cliquez sur Ajouter un filtre.
  5. Donnez un nom au filtre.
  6. Décidez si vous souhaitez afficher le filtre dans la Visionneuse oui ou non. Si vous l’affichez dans la Visionneuse, chacun qui a accès à un partage de rapport pourra sélectionner ce filtre.
  7. Ajoutez une ou plusieurs conditions. Vous pouvez filtrer sur les métadonnées des répondants, les métadonnées des contacts ou une question de l’enquête, ou une combinaison de celles-ci.
  8. Sélectionnez si les résultats doivent correspondre à au moins une de ces conditions ou à toutes ces conditions.
  9. Cliquez sur Enregistrer.

Le filtre sera appliqué immédiatement au partage. Il sera appliqué ensemble avec le filtre global si vous en avez défini un.

Attention ! Les personnes qui consultent le rapport à l’aide de ce partage ne peuvent voir que les données filtrées. Ils peuvent filtrer plus en profondeur – si vous autorisez les filtres rapides – mais ils ne pourront jamais désactiver les filtres de partage et / ou les filtres globaux.

Supprimer un filtre

  1. Allez vers le ReportBuilder et modifiez votre rapport.
  2. Cliquez sur la roue dentée dans le coin en haut à droite et cliquez sur Options.
  3. Allez vers l’onglet Filtres.
  4. Cliquez sur la poubelle  trash can iconà côté du filtre que vous souhaitez supprimer.
  5. Confirmez la suppression.

Si vous ne pouvez pas cliquer sur l’icône de la poubelle, ça veut dire que le filtre est encore utilisé. Il y aura aussi une indication en usage. Dans ce cas, désélectionnez d’abord le filtre du rapport ou de l’élément où il est encore utilisé et/ou supprimez les partages où ce filtre est appliqué.

Questions courantes

Le filtre est encore en usage. Êtes-vous sur de vouloir le supprimer ? Alors désélectionnez-le des filtres du rapport et des filtres de l’élément et supprimer les partages qui utilisent ce filtre. Puis réessayez.

Survolez le badge En usage pour voir où le filtre est encore utilisé.

Oui, c’est possible ! Une fois qu’un filtre a été créé à un niveau quelconque, il sera également disponible en tant que filtre prédéfini à d’autres niveaux.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.